*/*: [QA] Use consistent function definition formatting
[gentoo.git] / dev-perl / Exception-Base / Exception-Base-0.250.100.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DEXTER
7 DIST_VERSION=0.2501
8 inherit perl-module
9
10 DESCRIPTION="Error handling with exception class"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}
19         dev-perl/Module-Build
20         test? ( >=dev-perl/Test-Unit-Lite-0.120.0 )
21 "
22
23 src_install() {
24         perl-module_src_install
25         docompress -x usr/share/doc/${PF}/examples
26         insinto usr/share/doc/${PF}/
27         doins -r examples/
28 }