*/*: Drop stable ia64 keywords
[gentoo.git] / dev-perl / Devel-StackTrace / Devel-StackTrace-2.20.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=DROLSKY
7 DIST_VERSION=2.02
8 inherit perl-module
9
10 DESCRIPTION="An object representing a stack trace"
11
12 LICENSE="Artistic-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         virtual/perl-File-Spec
20         virtual/perl-Scalar-List-Utils
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? (
25                 >=virtual/perl-Test-Simple-0.960.0
26         )
27 "
28
29 src_test() {
30         perl_rm_files t/author-* t/release-*
31         perl-module_src_test
32 }