*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / Devel-CheckLib / Devel-CheckLib-1.110.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=MATTN
7 DIST_VERSION=1.11
8 inherit perl-module
9
10 DESCRIPTION="check that a library is available"
11
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ~ppc64 sparc x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="
18         >=virtual/perl-File-Temp-0.160.0
19         virtual/perl-Exporter
20         virtual/perl-File-Spec
21 "
22 DEPEND="${RDEPEND}
23         virtual/perl-ExtUtils-MakeMaker
24         test? (
25                 >=virtual/perl-Test-Simple-0.620.0
26                 >=dev-perl/IO-CaptureOutput-1.80.100
27                 >=dev-perl/Mock-Config-0.20.0
28         )
29 "