*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / DBIx-SearchBuilder / DBIx-SearchBuilder-1.670.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=BPS
7 DIST_VERSION=1.67
8 DIST_EXAMPLES=("ex/*")
9 inherit perl-module
10
11 DESCRIPTION="Encapsulate SQL queries and rows in simple Perl objects"
12
13 SLOT="0"
14 KEYWORDS="amd64 hppa ~ppc x86"
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=dev-perl/Cache-Simple-TimedExpiry-0.210.0
20         >=dev-perl/capitalization-0.30.0
21         >=dev-perl/Class-ReturnValue-0.400.0
22         dev-perl/Class-Accessor
23         dev-perl/Clone
24         dev-perl/DBI
25         dev-perl/DBIx-DBSchema
26         dev-perl/Want
27         >=virtual/perl-Encode-1.990.0
28         virtual/perl-Scalar-List-Utils
29 "
30 DEPEND="${RDEPEND}
31         >=virtual/perl-ExtUtils-MakeMaker-6.360.0
32         test? (
33                 >=virtual/perl-Test-Simple-0.520.0
34                 dev-perl/DBD-SQLite
35                 virtual/perl-File-Temp
36         )
37 "
38
39 PATCHES=( "${FILESDIR}/${PN}"-1.66-no-dot-inc.patch )
40
41 src_prepare() {
42         use test && perl_rm_files t/pod.t
43         perl-module_src_prepare
44 }