*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-perl / DBICx-TestDatabase / DBICx-TestDatabase-0.50.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=JROCKWAY
7 DIST_VERSION=0.05
8 inherit perl-module
9
10 DESCRIPTION="create a temporary database from a DBIx::Class::Schema"
11
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND="virtual/perl-File-Temp
18         >=dev-perl/DBD-SQLite-1.290.0
19         dev-perl/SQL-Translator
20 "
21 DEPEND="${RDEPEND}
22         >=virtual/perl-ExtUtils-MakeMaker-6.360.0
23         test? (
24                 dev-perl/DBIx-Class
25                 >=virtual/perl-Test-Simple-1.1.10
26         )
27 "
28 PERL_RM_FILES=("MYMETA.json" "MYMETA.yml") # https://rt.cpan.org/Ticket/Display.html?id=108141
29
30 src_prepare() {
31         sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
32                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
33         perl-module_src_prepare
34 }