*/*: Bump copyright on files touched this year
[gentoo.git] / dev-perl / Authen-Simple / Authen-Simple-0.500.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=CHANSEN
7 DIST_VERSION=0.5
8 inherit perl-module
9
10 DESCRIPTION="Simple Authentication"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 ia64 ppc ppc64 sparc x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         dev-perl/Class-Accessor
18         dev-perl/Class-Data-Inheritable
19         dev-perl/Crypt-PasswdMD5
20         virtual/perl-Digest-MD5
21         virtual/perl-Digest-SHA
22         virtual/perl-MIME-Base64
23         dev-perl/Params-Validate
24 "
25 DEPEND="${RDEPEND}
26         >=virtual/perl-ExtUtils-MakeMaker-6.360.0
27         test? ( virtual/perl-Test-Simple )
28 "
29
30 src_prepare() {
31         sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
32                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
33         perl-module_src_prepare
34 }