c8a407083927608abf10e5ec48143cc6c6e3ada0
[gentoo.git] / dev-ml / zed / zed-1.5.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit opam
7
8 DESCRIPTION="Zed is an abstract engine for text edition"
9 HOMEPAGE="https://github.com/diml/zed"
10 SRC_URI="https://github.com/diml/zed/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0/${PV}"
14 KEYWORDS="~amd64"
15 IUSE=""
16
17 DEPEND="
18         dev-lang/ocaml:=
19         dev-ml/camomile:=
20         dev-ml/react:="
21 RDEPEND="${DEPEND}"
22 DEPEND="${DEPEND}
23         dev-ml/jbuilder"
24
25 src_compile() {
26         jbuilder build --only-packages zed @install || die
27 }