sci-electronics/oregano: Remove last-rited pkg
[gentoo.git] / dev-ml / postgresql-ocaml / postgresql-ocaml-4.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit opam
7
8 MY_P="postgresql-${PV}"
9
10 DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
11 SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/${PV}/${MY_P}.tbz"
12 HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
13 IUSE=""
14
15 RDEPEND="
16         dev-db/postgresql:=[server]
17 "
18 DEPEND="${RDEPEND}
19         dev-ml/jbuilder
20         >=dev-ml/findlib-1.5"
21
22 SLOT="0/${PV}"
23 LICENSE="LGPL-2"
24 KEYWORDS="~amd64 ~ppc ~x86"
25
26 S="${WORKDIR}/${MY_P}"
27
28 src_compile() {
29         jbuilder build @install || die
30 }
31
32 src_install() {
33         opam_src_install "postgresql"
34 }