dev-ml/num: fix dependency
[gentoo.git] / dev-ml / num / num-1.3.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multilib findlib
7
8 DESCRIPTION="Library for arbitrary-precision integer and rational arithmetic"
9 HOMEPAGE="https://github.com/ocaml/num"
10 SRC_URI="https://github.com/ocaml/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1-with-linking-exception"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND=">=dev-lang/ocaml-4.09.0
18         >=dev-ml/findlib-1.8.1"
19 RDEPEND="${DEPEND}"
20 BDEPEND="${DEPEND}"
21
22 src_install() {
23         findlib_src_preinst
24         OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}"
25 }