dev-ml/dune: arm stable wrt bug #710374
[gentoo.git] / dev-ml / dune / dune-2.1.0.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multiprocessing
7
8 DESCRIPTION="A composable build system for OCaml"
9 HOMEPAGE="https://github.com/ocaml/dune"
10 SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0/${PV}"
14 KEYWORDS="amd64 arm ~arm64 ~x86"
15 IUSE="test"
16
17 DEPEND="dev-lang/ocaml"
18 RDEPEND="${DEPEND}
19         !dev-ml/jbuilder"
20 BDEPEND=""
21
22 RESTRICT="test"
23
24 src_configure() {
25         ocaml configure.ml --libdir "${EPREFIX}/usr/$(get_libdir)/ocaml" || die
26 }
27
28 src_install() {
29         default
30         mv "${D}"/usr/doc "${D}"/usr/share/doc/${PF}
31         mv "${D}"/usr/man "${D}"/usr/share/man
32 }