sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-libs / volume_key / volume_key-0.3.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit python-single-r1
9
10 DESCRIPTION="Library for manipulating and storing storage volume encryption keys"
11 HOMEPAGE="https://pagure.io/volume_key"
12 SRC_URI="http://releases.pagure.org/${PN}/${P}.tar.xz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="
23         ${PYTHON_DEPS}
24         app-crypt/gpgme
25         dev-libs/glib:2
26         dev-libs/nspr
27         dev-libs/nss
28         sys-apps/util-linux
29         sys-fs/cryptsetup:=
30 "
31 DEPEND="
32         ${RDEPEND}
33         sys-devel/gettext
34         test? ( dev-libs/nss[utils] )
35         "
36
37 pkg_setup() {
38         python-single-r1_pkg_setup
39 }
40
41 src_configure() {
42         # --without-python disables python2
43         econf --without-python --with-python3
44 }
45
46 src_install() {
47         default
48         find "${ED}" -name "*.la" -delete || die
49 }