sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-libs / qrosspython / qrosspython-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit git-r3 python-single-r1 cmake-utils
9
10 EGIT_REPO_URI="https://github.com/0xd34df00d/Qross.git"
11
12 DESCRIPTION="Python scripting backend for Qross"
13 HOMEPAGE="https://github.com/0xd34df00d/Qross"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="debug"
19
20 RDEPEND="
21         ~dev-libs/qrosscore-${PV}
22         dev-python/sip
23         dev-qt/qtcore:5
24         dev-qt/qtgui:5
25         ${PYTHON_DEPS}
26 "
27 DEPEND="${RDEPEND}
28         dev-qt/qttest:5
29 "
30
31 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
32
33 CMAKE_USE_DIR="${S}/src/bindings/python/qrosspython"
34
35 mycmakeargs=( -DUSE_QT5=ON )