*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-libs / processor-trace / processor-trace-1.6.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils
7
8 DESCRIPTION="Intel(R) Processor Trace decoder library"
9 HOMEPAGE="https://github.com/01org/processor-trace"
10 SRC_URI="https://github.com/01org/processor-trace/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT=0
14 KEYWORDS="-* ~amd64"
15 IUSE="doc test"
16 RESTRICT="!test? ( test )"
17
18 DEPEND="doc? ( app-text/pandoc )"
19
20 src_configure() {
21         local mycmakeargs=(
22                 -DMAN=$(usex doc)
23                 -DPTUNIT=$(usex test)
24         )
25
26         cmake-utils_src_configure
27 }