*/*: Drop stable ia64 keywords
[gentoo.git] / dev-libs / npth / npth-1.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit libtool
7
8 DESCRIPTION="New GNU Portable Threads Library"
9 HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
10 SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE="static-libs"
16
17 src_prepare() {
18         default
19         elibtoolize  # for Solaris shared library
20 }
21
22 src_configure() {
23         econf $(use_enable static-libs static)
24 }