*/*: Drop stable ia64 keywords
[gentoo.git] / dev-libs / mm / mm-1.4.2-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Shared Memory Abstraction Library"
7 HOMEPAGE="http://www.ossp.org/pkg/lib/mm/"
8 SRC_URI="ftp://ftp.ossp.org/pkg/lib/mm/${P}.tar.gz"
9
10 LICENSE="mm"
11 SLOT="1.2"
12 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
13 IUSE=""
14
15 src_prepare() {
16         default
17         sed -i Makefile.in \
18                 -e '/--mode=link/s| -o | $(LDFLAGS)&|g' \
19                 || die "sed Makefile.in"
20 }
21
22 src_configure() {
23         econf --disable-static
24 }
25
26 src_test() {
27         emake test
28 }
29
30 src_install() {
31         default
32         dodoc PORTING
33
34         # no static archive installed
35         find "${D}" -name '*.la' -delete || die
36 }