*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-libs / libindicator / libindicator-12.10.1-r201.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils flag-o-matic virtualx multilib-minimal
6
7 DESCRIPTION="A set of symbols and convience functions that all indicators would like to use"
8 HOMEPAGE="https://launchpad.net/libindicator"
9 SRC_URI="https://launchpad.net/${PN}/${PV%.*}/${PV}/+download/${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 RDEPEND=">=dev-libs/glib-2.22[${MULTILIB_USEDEP}]
18         >=x11-libs/gtk+-2.18:2[${MULTILIB_USEDEP}]"
19 DEPEND="${RDEPEND}
20         dev-util/glib-utils
21         virtual/pkgconfig[${MULTILIB_USEDEP}]
22         test? ( dev-util/dbus-test-runner )"
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${PN}-ldflags-spacing.patch
26         eautoreconf
27 }
28
29 multilib_src_configure() {
30         append-flags -Wno-error
31
32         myconf=(
33                 --disable-silent-rules
34                 --disable-static
35                 --with-gtk=2
36         )
37         local ECONF_SOURCE=${S}
38         econf "${myconf[@]}"
39 }
40
41 multilib_src_test() {
42         Xemake check #391179
43 }
44
45 multilib_src_install() {
46         emake -j1 DESTDIR="${D}" install
47 }
48
49 multilib_src_install_all() {
50         einstalldocs
51         prune_libtool_files --all
52
53         rm -vf \
54                 "${ED}"/usr/lib*/libdummy-indicator-* \
55                 "${ED}"/usr/share/${PN}/*indicator-debugging
56 }