*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-libs / libevdev / libevdev-1.8.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_6,3_7} )
7
8 inherit multilib-minimal python-any-r1
9
10 DESCRIPTION="Handler library for evdev events"
11 HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
12
13 if [[ ${PV} == 9999* ]] ; then
14         EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
15         inherit autotools git-r3
16 else
17         SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
18         KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86"
19 fi
20
21 LICENSE="MIT"
22 SLOT="0"
23 IUSE="doc static-libs"
24
25 BDEPEND="
26         ${PYTHON_DEPS}
27         doc? ( app-doc/doxygen )
28         virtual/pkgconfig
29 "
30 RESTRICT="test" # Tests need to run as root.
31
32 src_prepare() {
33         default
34         [[ ${PV} == 9999* ]] && eautoreconf
35 }
36
37 multilib_src_configure() {
38         ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
39 }
40
41 multilib_src_install() {
42         default
43         find "${D}" -name '*.la' -delete || die
44         if use doc ;then
45                 local HTML_DOCS=( doc/html/. )
46                 einstalldocs
47         fi
48 }