sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-libs / gobject-introspection-common / gobject-introspection-common-1.64.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 GNOME_ORG_MODULE="gobject-introspection"
6
7 inherit gnome.org
8
9 DESCRIPTION="Build infrastructure for GObject Introspection"
10 HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
11
12 LICENSE="HPND"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
15 IUSE=""
16
17 RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
18 # Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
19 # https://forums.gentoo.org/viewtopic-p-7421930.html
20
21 src_configure() { :; }
22
23 src_compile() { :; }
24
25 src_install() {
26         insinto /usr/share/aclocal
27         doins m4/introspection.m4
28
29         insinto /usr/share/gobject-introspection-1.0
30         doins Makefile.introspection
31 }