*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-libs / aws-checksums / aws-checksums-0.1.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils
7
8 DESCRIPTION="Cross-Platform HW accelerated CRC32c and CRC32 with software fallbacks"
9 HOMEPAGE="https://github.com/awslabs/aws-checksums"
10 SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 src_configure() {
20         local mycmakeargs=(
21                 -DBUILD_TESTING=$(usex test)
22         )
23         cmake-utils_src_configure
24 }