*/*: Specify EAPI=0 explicitly, to ease greps
[gentoo.git] / dev-java / sun-jacc-api / sun-jacc-api-20070102.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit java-pkg-2 java-ant-2
7
8 DESCRIPTION="Java Authorization Contract for Containers"
9 HOMEPAGE="http://java.sun.com/j2ee/javaacc/index.html"
10 # cvs -d :pserver:nichoj@cvs.dev.java.net:/cvs checkout glassfish/jacc-api
11 # cd glassfish
12 # mv jacc-api sun-jacc-api-${P}
13 # tar --exclude=CVS -cjvf sun-jacc-api-${P}.tar.bz2 sun-jacc-api-${P}
14 SRC_URI="mirror://gentoo/${P}.tar.bz2"
15
16 LICENSE="CDDL"
17 SLOT="0"
18 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
19 IUSE=""
20
21 COMMON_DEP="=dev-java/servletapi-2.4*"
22 DEPEND=">=virtual/jdk-1.4
23         ${COMMON_DEP}"
24 RDEPEND=">=virtual/jre-1.4
25         ${COMMON_DEP}"
26
27 src_unpack() {
28         unpack ${A}
29         cd "${S}"
30         # we need to patch the build file since we don't want to update an
31         # existing jar-archive but build a new one (called jcc-api.jar)
32         epatch "${FILESDIR}/20070102-jcc-api.patch"
33         java-pkg_jar-from servletapi-2.4 servlet-api.jar
34 }
35
36 src_compile() {
37         eant -Djavaee.jar=servlet-api.jar
38 }
39
40 src_install() {
41         java-pkg_dojar jcc-api.jar
42 }