dev-java/java-config: DISTUTILS_USE_SETUPTOOLS=no
[gentoo.git] / dev-java / java-config / java-config-2.2.0-r4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # jython depends on java-config, so don't add it or things will break
7 PYTHON_COMPAT=( python{3_6,3_7} )
8 DISTUTILS_USE_SETUPTOOLS=no
9
10 inherit distutils-r1
11
12 DESCRIPTION="Java environment configuration query tool"
13 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
14 SRC_URI="https://dev.gentoo.org/~gyakovlev/distfiles/${P}.tar.bz2"
15
16 LICENSE="GPL-2"
17 SLOT="2"
18 KEYWORDS="amd64 ~arm arm64 ppc64 x86"
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 DEPEND="test? ( sys-apps/portage[${PYTHON_USEDEP}] )"
23
24 # baselayout-java is added as a dep till it can be added to eclass.
25 RDEPEND="
26         !dev-java/java-config-wrapper
27         sys-apps/baselayout-java
28         sys-apps/portage[${PYTHON_USEDEP}]"
29
30 PATCHES=( "${FILESDIR}"/${PN}-2.2.0-prefix.patch )
31
32 python_install_all() {
33         distutils-r1_python_install_all
34
35         # This replaces the file installed by java-config-wrapper.
36         dosym java-config-2 /usr/bin/java-config
37 }
38
39 python_test() {
40         esetup.py test
41 }