dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / vector / vector-0.11.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.4.6.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: #666812
9 inherit haskell-cabal
10
11 DESCRIPTION="Efficient Arrays"
12 HOMEPAGE="https://github.com/haskell/vector"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
18 IUSE="+boundschecks internalchecks unsafechecks"
19
20 RESTRICT=test # -O2 -g makes tests build hang
21
22 RDEPEND=">=dev-haskell/primitive-0.5.0.1:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
23         >=dev-lang/ghc-7.4.1:=
24 "
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-1.10
27 "
28
29 PATCHES=("${FILESDIR}"/${P}-primitive-0.6.2.0.patch)
30
31 src_prepare() {
32         default
33
34         cabal_chdeps \
35                 "QuickCheck >=  2.7  && < 2.8" "QuickCheck >=  2.7" \
36                 'base >= 4.3 && < 4.9' 'base >= 4.3' \
37                 'ghc-prim >= 0.2 && < 0.5' 'ghc-prim >= 0.2'
38 }
39
40 src_configure() {
41         haskell-cabal_src_configure \
42                 $(cabal_flag boundschecks boundschecks) \
43                 $(cabal_flag internalchecks internalchecks) \
44                 $(cabal_flag unsafechecks unsafechecks)
45 }