*/*: Bump copyright on files touched this year
[gentoo.git] / dev-haskell / text / text-0.11.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.2.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="An efficient packed Unicode text type"
12 HOMEPAGE="https://github.com/bos/text"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
18 IUSE="developer"
19
20 RDEPEND=">=dev-lang/ghc-6.10.4:="
21 DEPEND="${RDEPEND}
22                 >=dev-haskell/cabal-1.8
23                 test? ( >=dev-haskell/hunit-1.2
24                         >=dev-haskell/quickcheck-2.4
25                         dev-haskell/random
26                         >=dev-haskell/test-framework-0.4
27                         >=dev-haskell/test-framework-hunit-0.2
28                         >=dev-haskell/test-framework-quickcheck2-0.2
29                 )"
30
31 src_configure() {
32         haskell-cabal_src_configure \
33                 $(cabal_flag developer developer)
34 }