dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / quickcheck / quickcheck-2.8.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7 #hackport: flags: +base4,-base3,templatehaskell:template-haskell
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 MY_PN="QuickCheck"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="Automatic testing of Haskell programs"
16 HOMEPAGE="https://github.com/nick8325/quickcheck"
17 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="2/${PV}"
21 KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux"
22 IUSE="+template-haskell"
23
24 RESTRICT=test # to avoid test circular depends
25
26 RDEPEND="dev-haskell/random:=[profile?]
27         >=dev-haskell/tf-random-0.4:=[profile?]
28         >=dev-haskell/transformers-0.2:=[profile?]
29         >=dev-lang/ghc-7.4.1:=
30 "
31 DEPEND="${RDEPEND}
32         >=dev-haskell/cabal-1.8
33         test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
34 "
35
36 S="${WORKDIR}/${MY_P}"
37
38 src_configure() {
39         haskell-cabal_src_configure \
40                 --flag=-base3 \
41                 --flag=base4 \
42                 $(cabal_flag template-haskell templatehaskell)
43 }