dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / hscolour / hscolour-1.24.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle"
9 # avoid Cabal dependency as it's a dependency of most packages
10 # including cabal depends.
11 CABAL_FEATURES+=" nocabaldep"
12 inherit haskell-cabal
13
14 DESCRIPTION="Colourise Haskell code"
15 HOMEPAGE="http://code.haskell.org/~malcolm/hscolour/"
16 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
17
18 LICENSE="LGPL-2.1"
19 SLOT="0/${PV}"
20 KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
21 IUSE=""
22
23 RDEPEND=">=dev-lang/ghc-7.4.1:=
24 "
25 DEPEND="${RDEPEND}"
26
27 src_configure() {
28         # llvm-general-pure passes rtsopts
29         haskell-cabal_src_configure --ghc-options=-rtsopts
30 }
31
32 src_install() {
33         cabal_src_install
34         if use doc; then
35                 dohtml hscolour.css
36         fi
37 }