dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / hashed-storage / hashed-storage-0.5.11.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Hashed file storage support code"
12 HOMEPAGE="http://hackage.haskell.org/package/hashed-storage"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~ppc-macos ~x86-macos"
18 IUSE="diff hpc test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="dev-haskell/binary:=[profile?]
22         dev-haskell/dataenc:=[profile?]
23         dev-haskell/extensible-exceptions:=[profile?]
24         >=dev-haskell/mmap-0.5:=[profile?] <dev-haskell/mmap-0.6:=[profile?]
25         dev-haskell/mtl:=[profile?]
26         dev-haskell/zlib:=[profile?]
27         >=dev-lang/ghc-7.4.1:=
28         diff? ( dev-haskell/lcs:=[profile?] )
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.6
32         test? ( dev-haskell/hunit:=[profile?]
33                 >=dev-haskell/quickcheck-2.3:2=[profile?]
34                 dev-haskell/test-framework:=[profile?]
35                 dev-haskell/test-framework-hunit:=[profile?]
36                 dev-haskell/test-framework-quickcheck2:=[profile?]
37                 dev-haskell/zip-archive:=[profile?] )
38 "
39
40 src_prepare() {
41         epatch "${FILESDIR}"/${P}-ghc-7.10.patch
42         epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
43 }
44
45 src_configure() {
46         haskell-cabal_src_configure \
47                 $(cabal_flag diff diff) \
48                 $(cabal_flag hpc hpc) \
49                 $(cabal_flag test test)
50 }
51
52 src_install() {
53         haskell-cabal_src_install
54
55         use test && rm "${ED}/usr/bin/hashed-storage-test"
56 }