dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / gtk2hs-buildtools / gtk2hs-buildtools-0.13.0.4-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="bin"
9 inherit haskell-cabal
10
11 DESCRIPTION="Tools to build the Gtk2Hs suite of User Interface libraries"
12 HOMEPAGE="http://projects.haskell.org/gtk2hs/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
18 IUSE="+closuresignals"
19
20 RDEPEND="dev-haskell/random:=
21         dev-haskell/hashtables:=
22         >=dev-lang/ghc-7.4.1:=
23 "
24 DEPEND="${RDEPEND}
25         dev-haskell/alex
26         >=dev-haskell/cabal-1.8
27         dev-haskell/happy
28 "
29
30 src_prepare() {
31         epatch "${FILESDIR}"/${P}-ia64.patch
32         epatch "${FILESDIR}"/${P}-alex-3.1.6.patch
33 }
34
35 src_configure() {
36         haskell-cabal_src_configure \
37                 $(cabal_flag closuresignals closuresignals)
38 }