dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / cairo / cairo-0.13.1.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7 #hackport: flags: cairo_ps:postscript,cairo_pdf:pdf,cairo_svg:svg
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Binding to the Cairo library"
13 HOMEPAGE="http://projects.haskell.org/gtk2hs/"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
19 IUSE="+pdf +postscript +svg"
20
21 RDEPEND="dev-haskell/mtl:=[profile?]
22         >=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
23         >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
24         >=dev-lang/ghc-7.4.1:=
25         x11-libs/cairo
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.18
29         dev-haskell/gtk2hs-buildtools
30         virtual/pkgconfig
31 "
32
33 src_configure() {
34         haskell-cabal_src_configure \
35                 $(cabal_flag pdf cairo_pdf) \
36                 $(cabal_flag postscript cairo_ps) \
37                 $(cabal_flag svg cairo_svg)
38 }