dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / ansi-terminal / ansi-terminal-0.6.2.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Simple ANSI terminal support, with Windows compatibility"
12 HOMEPAGE="https://github.com/feuerbach/ansi-terminal"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
18 IUSE="example"
19
20 RDEPEND=">=dev-lang/ghc-7.4.1:=
21 "
22 DEPEND="${RDEPEND}
23         >=dev-haskell/cabal-1.6
24 "
25
26 src_configure() {
27         haskell-cabal_src_configure \
28                 $(cabal_flag example example)
29 }