65b8737b5014605ede31c856b2b3ffdcb65fa82a
[gentoo.git] / dev-go / siphash / siphash-1.1.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit golang-build golang-vcs-snapshot
7
8 EGO_SRC=github.com/dchest/siphash
9 EGO_PN=${EGO_SRC}/...
10 EGIT_COMMIT="v${PV}"
11 SRC_URI="https://github.com/dchest/siphash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 DESCRIPTION="Go implementation of SipHash-2.4"
14 HOMEPAGE="https://github.com/dchest/siphash"
15
16 KEYWORDS="~amd64 ~arm ~x86"
17
18 LICENSE="CC0-1.0"
19 SLOT="0"
20 IUSE=""
21
22 DEPEND=""
23 RDEPEND=""