dev-erlang/esip: Version bump
[gentoo.git] / dev-erlang / esip / esip-1.0.32.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit rebar
7
8 DESCRIPTION="ProcessOne SIP server component"
9 HOMEPAGE="https://github.com/processone/esip"
10 SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
11         -> ${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
16
17 DEPEND=">=dev-lang/erlang-17.1
18         >=dev-erlang/fast_tls-1.1.4
19         >=dev-erlang/stun-1.0.31
20         >=dev-erlang/p1_utils-1.0.18"
21 RDEPEND="${DEPEND}"
22
23 DOCS=( CHANGELOG.md README.md )
24
25 src_prepare() {
26         rebar_src_prepare
27         rebar_fix_include_path stun
28
29         # ebin contains lonely .gitignore file asking for removal.
30         rm -r "${S}/ebin" || die
31 }