sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-embedded / usbprog / usbprog-0.2.0-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 WX_GTK_VER="3.0"
6
7 inherit eutils wxwidgets
8
9 DESCRIPTION="flashtool for the multi purpose programming adapter usbprog"
10 HOMEPAGE="http://www.embedded-projects.net/index.php?page_id=215"
11 #SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
12 SRC_URI="mirror://gentoo/${P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="static-libs X"
18
19 RDEPEND="
20         X? ( x11-libs/wxGTK:${WX_GTK_VER} )
21         >=dev-libs/libxml2-2.0.0
22         net-misc/curl
23         virtual/libusb:0
24         sys-libs/readline:0
25 "
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig
28 "
29
30 src_prepare() {
31         epatch "${FILESDIR}"/${P}-wx3.0.patch
32 }
33
34 src_configure() {
35         use X && need-wxwidgets unicode
36         econf \
37                 $(use_enable X gui) \
38                 $(use_enable static-libs static)
39 }
40
41 src_install() {
42         default
43         use static-libs || find "${ED}" -name '*.la' -delete
44 }