sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-embedded / sunxi-tools / sunxi-tools-1.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit eutils toolchain-funcs
7
8 MY_PV="v${PV}"
9 SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
10
11 DESCRIPTION="Tools for Allwinner A10 devices."
12 HOMEPAGE="http://linux-sunxi.org/"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE=""
17 KEYWORDS="~amd64"
18
19 DEPEND="virtual/libusb"
20
21 src_compile() {
22         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
23 }
24
25 src_install() {
26         dobin bin2fex bootinfo fel fex2bin fexc nand-part phoenix_info pio
27 }