sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-embedded / stlink / stlink-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit cmake-utils udev
7
8 DESCRIPTION="stm32 discovery line linux programmer"
9 HOMEPAGE="https://github.com/texane/stlink"
10 if [[ ${PV} == "9999" ]]; then
11         EGIT_REPO_URI="https://github.com/texane/stlink.git"
12         inherit git-r3
13 else
14         SRC_URI="https://github.com/texane/stlink/archive/${PV}/${P}.tar.gz"
15         KEYWORDS="~amd64"
16 fi
17
18 LICENSE="BSD"
19 SLOT="0"
20 IUSE=""
21
22 RDEPEND="virtual/libusb:1
23         >=dev-libs/glib-2.32.0:2
24         x11-libs/gtk+:3"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig"
27
28 src_configure() {
29         local mycmakeargs=(
30                 -DSTLINK_UDEV_RULES_DIR="$(get_udevdir)"/rules.d
31                 -DSTLINK_MODPROBED_DIR="${EPREFIX}/etc/modprobe.d"
32                 -DLIB_INSTALL_DIR:PATH="$(get_libdir)"
33         )
34
35         cmake-utils_src_configure
36 }