dev-dotnet/gtk-sharp: ppc stable wrt bug #594356
[gentoo.git] / dev-dotnet / gtk-sharp / gtk-sharp-2.12.21.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit dotnet autotools base
8
9 SLOT="2"
10 DESCRIPTION="gtk bindings for mono"
11 LICENSE="GPL-2"
12 HOMEPAGE="http://www.mono-project.com/GtkSharp"
13 KEYWORDS="amd64 ppc ~x86"
14 SRC_URI="http://download.mono-project.com/sources/gtk-sharp212/${P}.tar.gz"
15 IUSE="debug"
16
17 RESTRICT="test"
18
19 RDEPEND="
20         >=dev-lang/mono-3.0
21         x11-libs/pango
22         >=dev-libs/glib-2.31
23         dev-libs/atk
24         x11-libs/gtk+:2
25         gnome-base/libglade
26         dev-perl/XML-LibXML
27         !dev-dotnet/gtk-sharp-gapi
28         !dev-dotnet/gtk-sharp-docs
29         !dev-dotnet/gtk-dotnet-sharp
30         !dev-dotnet/gdk-sharp
31         !dev-dotnet/glib-sharp
32         !dev-dotnet/glade-sharp
33         !dev-dotnet/pango-sharp
34         !dev-dotnet/atk-sharp"
35 DEPEND="${RDEPEND}
36         virtual/pkgconfig
37         sys-devel/automake:1.11"
38
39 src_prepare() {
40         base_src_prepare
41         eautoreconf
42         libtoolize
43 }
44
45 src_configure() {
46         econf   --disable-static \
47                 --disable-dependency-tracking \
48                 --disable-maintainer-mode \
49                 $(use_enable debug)
50 }
51
52 src_compile() {
53         emake
54 }
55
56 src_install() {
57         default
58         dotnet_multilib_comply
59         sed -i "s/\\r//g" "${D}"/usr/bin/* || die "sed failed"
60 }