Convert all URIs for launchpad.net from http to https
[gentoo.git] / dev-db / mydumper / mydumper-0.6.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit cmake-utils versionator
7
8 DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL and Drizzle"
9 HOMEPAGE="https://launchpad.net/mydumper"
10 SRC_URI="https://launchpad.net/mydumper/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc"
15
16 RDEPEND="dev-libs/libpcre
17         virtual/mysql
18         dev-libs/glib:2"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig
21         doc? ( <dev-python/sphinx-1.3 )"
22
23 DOCS=( README )
24
25 src_prepare() {
26         # respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
27         sed -i -e 's:-Werror -O3 -g:${CMAKE_C_FLAGS}:' CMakeLists.txt
28         # fix doc install path
29         sed -i -e "s:share/doc/mydumper:share/doc/${PF}:" docs/CMakeLists.txt
30 }
31
32 src_configure() {
33         mycmakeargs=( $(cmake-utils_use doc BUILD_DOCS) )
34
35         cmake-utils_src_configure
36 }