*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-cpp / libgnomecanvasmm / libgnomecanvasmm-2.26.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6 GNOME_TARBALL_SUFFIX="bz2"
7
8 inherit flag-o-matic gnome2
9
10 DESCRIPTION="C++ bindings for libgnomecanvas"
11 HOMEPAGE="https://www.gtkmm.org"
12
13 LICENSE="LGPL-2.1"
14 SLOT="2.6"
15 KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 sparc x86"
16 IUSE="doc examples"
17
18 RDEPEND="
19         >=gnome-base/libgnomecanvas-2.6
20         >=dev-cpp/gtkmm-2.4:2.4
21 "
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig
24         doc? ( app-doc/doxygen )
25 "
26
27 src_prepare() {
28         if ! use examples; then
29                 # don't waste time building the examples
30                 sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
31                         die "sed Makefile.in failed"
32         fi
33         gnome2_src_prepare
34         append-cxxflags -std=c++11 #568300
35 }
36
37 src_compile() {
38         gnome2_src_compile
39
40         if use doc; then
41                 cd "${S}/docs/reference"
42                 emake all
43         fi
44 }
45
46 src_install() {
47         gnome2_src_install
48
49         if use doc ; then
50                 dohtml -r docs/reference/html/*
51         fi
52
53         if use examples; then
54                 cp -R examples "${D}/usr/share/doc/${PF}"
55         fi
56 }