*/*: Bump copyright on files touched this year
[gentoo.git] / dev-cpp / gconfmm / gconfmm-2.28.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6 GNOME2_LA_PUNT="yes"
7 GNOME_TARBALL_SUFFIX="bz2"
8
9 inherit flag-o-matic gnome2
10
11 DESCRIPTION="C++ bindings for GConf"
12 HOMEPAGE="https://www.gtkmm.org"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86"
17 IUSE="doc"
18
19 RDEPEND="
20         >=gnome-base/gconf-2.4:2
21         >=dev-cpp/glibmm-2.12:2[doc?]
22         >=dev-cpp/gtkmm-2.4:2.4
23 "
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig
26 "
27
28 src_configure() {
29         append-cxxflags -std=c++11 #568580
30         gnome2_src_configure \
31                 $(use_enable doc documentation)
32 }
33
34 src_install() {
35         gnome2_src_install
36
37         if use doc ; then
38                 dohtml -r docs/reference/html/*
39         fi
40 }