sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / app-vim / haskellmode / haskellmode-20101118-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 VIM_PLUGIN_VIM_VERSION="7.1"
7
8 inherit vim-plugin
9
10 DESCRIPTION="vim plugin: Provides IDE-like features for Haskell development"
11 HOMEPAGE="http://projects.haskell.org/haskellmode-vim"
12 SRC_URI="http://code.haskell.org/~wwolff/haskellmode/${P}.tar.bz2"
13
14 LICENSE="BSD"
15 SLOT=0
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="
19         ${RDEPEND}"
20
21 RDEPEND="
22         dev-lang/ghc[doc]
23         net-misc/wget"
24
25 VIM_PLUGIN_HELPFILES="haskellmode"
26 VIM_PLUGIN_MESSAGES="filetype"
27
28 pkg_postinst() {
29         vim-plugin_pkg_postinst
30
31         elog "You must set 'g:haddock_browser' to the path of your preferred browser, and"
32         elog "depending on your setup you may also want to change the default value of"
33         elog "'g:haddock_browser_callformat' (see ':help g:haddock_browser_callformat' for"
34         elog "full usage info). You can persist these settings in your vimrc file, for"
35         elog "example:"
36         elog
37         elog "    let g:haddock_browser=\"/usr/bin/elinks\""
38         elog "    let g:haddock_browser_callformat=\"%s file://%s >/dev/null 2>&1 &\""
39         elog
40         elog "To enable GHC compiler integration, also add the following to your vimrc:"
41         elog
42         elog "    au BufEnter *.hs compiler ghc"
43         elog
44         elog "The first time you load haskellmode, you must generate a Haddock index. Do"
45         elog "this with the command:"
46         elog
47         elog "    :ExportDocIndex"
48         elog
49         elog "Consult ${HOMEPAGE} for further setup and usage information."
50 }