5bdce94124c0afd456cbf66542c4a604f240408a
[gentoo.git] / app-text / groonga-normalizer-mysql / groonga-normalizer-mysql-1.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils autotools ltprune
6
7 DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
8 HOMEPAGE="http://groonga.org/"
9 SRC_URI="http://packages.groonga.org/source/${PN}/${P}.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="app-text/groonga"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19 DOCS=( README.md )
20
21 src_prepare() {
22         default_src_prepare
23         eautoreconf
24 }
25
26 src_configure() {
27         # ruby is only uses for tests
28         econf \
29                 --without-ruby \
30                 --docdir="${EROOT}usr/share/doc/${P}"
31 }
32
33 src_install() {
34         default
35
36         prune_libtool_files
37         rm -r "${D}usr/share/doc/${PN}" || die
38 }