app-text/groonga-normalizer-mysql: update homepage
[gentoo.git] / app-text / groonga-normalizer-mysql / groonga-normalizer-mysql-1.0.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils autotools ltprune
6
7 DESCRIPTION="Groonga plugin that provides MySQL compatible normalizers"
8 HOMEPAGE="https://groonga.org/"
9 SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="app-text/groonga"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19 DOCS=( README.md )
20
21 src_prepare() {
22         eautoreconf
23 }
24
25 src_configure() {
26         econf \
27                 --without-ruby19 \
28                 --docdir="${EROOT}usr/share/doc/${P}"
29 }
30
31 src_install() {
32         default
33
34         prune_libtool_files
35         # Dont install README twice nor license
36         rm -r "${D}usr/share/doc/${PN}" || die
37 }