*/*: Discontinue Gentoo SuperH port
[gentoo.git] / app-text / dvisvgm / dvisvgm-2.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs flag-o-matic
7
8 DESCRIPTION="Converts DVI files to SVG"
9 HOMEPAGE="https://dvisvgm.de/"
10 SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
15 IUSE="test"
16 # Tests don't work from $WORKDIR: kpathsea tries to search in relative
17 # directories from where the binary is executed.
18 # We cannot really use absolute paths in the kpathsea configuration since that
19 # would make it harder for prefix installs.
20 RESTRICT="test"
21
22 # TODO unbundle app-arch/brotli
23 RDEPEND="virtual/tex-base
24         >=app-arch/brotli-1.0.5
25         app-text/ghostscript-gpl
26         dev-libs/kpathsea:=
27         >=dev-libs/xxhash-0.6.5
28         >=media-gfx/potrace-1.10-r1
29         media-libs/freetype:2
30         >=media-libs/woff2-1.0.2
31         dev-libs/kpathsea
32         sys-libs/zlib"
33 DEPEND="${RDEPEND}
34         app-text/xmlto
35         app-text/asciidoc
36         dev-libs/libxslt
37         virtual/pkgconfig
38         test? ( dev-cpp/gtest )"
39
40 src_configure() {
41         local myargs=(
42                 --without-ttfautohint
43         )
44         econf "${myargs[@]}"
45 }