7fd1242e9b98fd052abf558b7319f8369f256fd9
[gentoo.git] / app-text / cwtext / cwtext-0.96.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils toolchain-funcs
5
6 DESCRIPTION="Text to Morse Code converter"
7 HOMEPAGE="http://cwtext.sourceforge.net"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="amd64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
13 IUSE=""
14
15 src_unpack() {
16         unpack ${A}
17         cd "${S}"
18
19         # change install directory to ${S}
20         sed -i -e "/^PREFIX/ s:=.*:=\"${S}\":" makefile || \
21                 die "sed makefile failed"
22
23         epatch "${FILESDIR}"/${PN}-0.94-asneeded.patch
24         tc-export CC
25 }
26
27 src_install() {
28         dobin cwtext cwpcm cwmm || die "dobin failed"
29
30         dodoc Changes README TODO
31 }