sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / app-shells / zsh-syntax-highlighting / zsh-syntax-highlighting-0.7.0_beta1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit readme.gentoo-r1
7
8 if [[ -z ${PV%%*9999} ]]; then
9         EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
10         inherit git-r3
11 else
12         MY_PV=$(ver_rs 3 -)
13         SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
14         KEYWORDS="amd64 x86"
15         S="${WORKDIR}/${PN}-${MY_PV}"
16 fi
17
18 DESCRIPTION="Fish shell like syntax highlighting for zsh"
19 HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
20
21 LICENSE="BSD"
22 SLOT="0"
23
24 RDEPEND="app-shells/zsh"
25
26 DISABLE_AUTOFORMATTING="true"
27 DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
28 . /usr/share/zsh/site-functions/zsh-syntax-highlighting.zsh
29 at the end of your ~/.zshrc"
30
31 src_prepare() {
32         sed -i -e 's/COPYING.md//' Makefile || die
33         default
34 }
35
36 src_install() {
37         emake \
38                 SHARE_DIR="${ED}/usr/share/zsh/site-functions" \
39                 DOC_DIR="${ED}/usr/share/doc/${PF}" \
40                 install
41         readme.gentoo_create_doc
42 }