*/*: [QA] Remove redundant `|| die` guards
[gentoo.git] / app-shells / localshell / localshell-1.3.4-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit base eutils
7
8 DESCRIPTION="Localshell allows per-user/group local control of shell execution"
9 HOMEPAGE="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary"
10 SRC_URI="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc ~ppc64 x86"
15 IUSE=""
16
17 src_configure() {
18         # this is a shell, it needs to be in /bin
19         econf --bindir=/bin --sysconfdir=/etc
20 }
21
22 src_install() {
23         emake install DESTDIR="${D}"
24         rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
25 }
26
27 pkg_postinst() {
28         elog "Remember to add /bin/localshell to /etc/shells and create"
29         elog "/etc/localshell.conf based on the included configuration examples"
30 }