dev-python/objgraph: keyworded 3.4.1 for ia64, bug #717946
[gentoo.git] / app-shells / ctypes-sh / ctypes-sh-1.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools toolchain-funcs
7
8 DESCRIPTION="Foreign function interface for bash"
9 HOMEPAGE="http://ctypes.sh/"
10 SRC_URI="https://github.com/taviso/${PN/-/.}/releases/download/v${PV}/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND="virtual/libffi
17         virtual/libelf
18         app-arch/xz-utils
19         app-arch/bzip2
20         app-shells/bash[plugins]"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 PATCHES=(
25         "${FILESDIR}/${P}-makefile-fix.patch"
26 )
27
28 src_prepare() {
29         default
30         eautoreconf
31 }
32
33 src_test() {
34         pushd test
35         PATH="${S}:${PATH}" \
36                 LD_LIBRARY_PATH="${S}/src/.libs" \
37                 make CC="$(tc-getCC)" || die "make check failed"
38         popd
39 }