*/*: Discontinue Gentoo SuperH port
[gentoo.git] / app-portage / ufed / ufed-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 if [[ ${PV} == *9999 ]]; then
7         inherit git-r3
8         EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/ufed.git"
9 else
10         SRC_URI="https://gitweb.gentoo.org/proj/ufed.git/snapshot/${P}.tar.bz2"
11         KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
12 fi
13
14 inherit autotools out-of-source
15
16 DESCRIPTION="Gentoo Linux USE flags editor"
17 HOMEPAGE="https://wiki.gentoo.org/wiki/Ufed"
18
19 LICENSE="GPL-2"
20 SLOT="0"
21 IUSE=""
22
23 RDEPEND="
24         dev-lang/perl
25         sys-libs/ncurses:0="
26 DEPEND="${RDEPEND}
27         virtual/pkgconfig"
28
29 src_prepare() {
30         default
31         # Change the version number to reflect the ebuild version
32         local REPLACEMENT_VERSION_STR="${PVR}"
33         [[ ${PV} == *9999 ]] && REPLACEMENT_VERSION_STR+="-${EGIT_VERSION}"
34         sed -i "s:,\[git\],:,\[${REPLACEMENT_VERSION_STR}\],:" configure.ac || die
35
36         eautoreconf
37 }