*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / app-portage / smart-live-rebuild / smart-live-rebuild-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
6
7 EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
8 inherit distutils-r1 git-r3
9
10 DESCRIPTION="Check live packages for updates and emerge them as necessary"
11 HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
12 SRC_URI=""
13
14 LICENSE="BSD-2"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
18
19 RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
20
21 python_test() {
22         esetup.py test
23 }
24
25 python_install_all() {
26         distutils-r1_python_install_all
27
28         insinto /etc/portage
29         newins smart-live-rebuild.conf{.example,}
30         insinto /usr/share/portage/config/sets
31         newins sets.conf.example smart-live-rebuild.conf
32 }