*/*: Discontinue Gentoo SuperH port
[gentoo.git] / app-portage / repoman / repoman-2.3.16.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 PYTHON_REQ_USE='bzip2(+)'
8
9 inherit distutils-r1
10
11 if [[ ${PV} == *9999 ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
14         S="${WORKDIR}/${P}/repoman"
15 else
16         SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
17         KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
18 fi
19
20 DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
21 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
22
23 LICENSE="GPL-2"
24 SLOT="0"
25 IUSE=""
26
27 RDEPEND="
28         >=sys-apps/portage-2.3.43[${PYTHON_USEDEP}]
29         >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
30         dev-python/pyyaml[${PYTHON_USEDEP}]
31 "
32 DEPEND="${RDEPEND}"
33
34 python_test() {
35         esetup.py test
36 }
37
38 python_install() {
39         # Install sbin scripts to bindir for python-exec linking
40         # they will be relocated in pkg_preinst()
41         distutils-r1_python_install \
42                 --system-prefix="${EPREFIX}/usr" \
43                 --bindir="$(python_get_scriptdir)" \
44                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
45                 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
46                 --sbindir="$(python_get_scriptdir)" \
47                 --sysconfdir="${EPREFIX}/etc" \
48                 "${@}"
49 }
50
51 pkg_postinst() {
52         if [[ -z {REPLACING_VERSIONS} ]]; then
53                 elog ""
54                 elog "This release of repoman is from the new portage/repoman split"
55                 elog "release code base."
56                 elog "This new repoman code base is still being developed.  So its API's"
57                 elog "are not to be considered stable and are subject to change."
58                 elog "The code released has been tested and considered ready for use."
59                 elog "This however does not guarantee it to be completely bug free."
60                 elog "Please report any bugs you may encounter."
61                 elog ""
62         fi
63 }