*/*: [QA] Remove redundant `|| die` guards
[gentoo.git] / app-office / unoconv / unoconv-0.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6} )
7
8 inherit eutils python-single-r1
9
10 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
11
12 DESCRIPTION="Convert between document formats supported by Libreoffice"
13 HOMEPAGE="http://dag.wiee.rs/home-made/unoconv/"
14 SRC_URI="https://github.com/dagwieers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18
19 KEYWORDS="~amd64 ~x86"
20
21 IUSE=""
22
23 DEPEND=""
24 RDEPEND="${DEPEND}
25         ${PYTHON_DEPS}
26         !app-text/odt2txt
27         virtual/ooo
28 "
29
30 src_prepare() {
31         eapply "${FILESDIR}/timeout.patch"
32         eapply_user
33         python_fix_shebang .
34 }
35
36 src_compile() { :; }
37
38 src_install() {
39         emake -j1 doc-install install install-links DESTDIR="${D}"
40
41         dodoc ChangeLog CHANGELOG.md README.adoc
42 }